在Eclipse中切换某个项目的JDK版本(或者启动项目报错java.lang.IllegalArgumentException: null)

技术标签: JDK  项目  报错  java.lang.IllegalArgumentExcep

有时候启动项目报错java.lang.IllegalArgumentException: null,其中一个原因是该项目所需的jdk版本和本机的jdk版本不符合,需要切换jdk版本。
1.有时候Eclipse里有几个项目,每个项目使用的JDK版本又不同,则需要切换。安装JDK步骤省略,以下步骤是安装完毕所需JDK版本开始设置的。
2.先把所需的JDK版本添加到项目Eclipse中来。Window->preferences->java->Installed JRES ->Add.
3.选择Standard VM,然后Next。
4.选择JDK版本安装路径,然后Finish。

5.然后所需JDK版本添加进来了。Apply->OK.


6.右键点击你的整个java项目,选择Build Path->Configure Build Path.
7.选择左侧Java Build Path,选中JRE System Library,选择右侧Editor。
8.选择Environments.

9.选择javaSE->JDK1.6。然后OK。


10.然后就有自己需要的版本,Finish->Apply->OK.设置完毕。

版权声明:本文为博主原创文章,遵循版权协议,转载请附上原文出处链接和本声明。
本文链接:
上海时时乐 飞速赛车平台 极速快乐8 山东十一运夺金 韩国1.5分彩 德国时时彩 三分快3 欢乐生肖 王者彩票开户 优优彩票APP